Overview
When a user in your Incydr environment has multiple agents with the same computer ID, problems such as backup never reaching 100% can occur. These problems can potentially lead to data loss. To resolve this issue, Incydr automatically detects the duplicate ID and assigns it a new one, creating a new agent in your environment. This article explains how Incydr resolves duplicate IDs, what you can do to prevent them, and how to troubleshoot the process.
Causes
The following actions can cause devices to have duplicate computer IDs (GUIDs):
- Cloning a virtual machine that has an Incydr agent installed and running on both virtual machines at the same time.
- Using Time Machine to restore a Mac from a backup.
- Using a third-party utility, such as Carbon Copy Cloner, to exactly duplicate a system state.
Diagnosing
When Incydr detects that multiple agents are using the same ID, it assigns a new ID to the duplicate agent. This means:
- A new agent appears in the Incydr console for the user. The new agent has "- duplicate 1" added to the name.
- For example, if the agent is named Saceanu OS X, the newly created device is named Saceanu OS X - duplicate 1.
- If the user has more than two agents with the same ID, the number increments, as in "duplicate 2", "duplicate 3", and so on.
- On the newly created agent, the backup agent prompts the user to sign in again with the user's account password.
Solution
To avoid the problem of multiple user devices having the same ID, do not take the actions listed above that cause duplicate IDs.
(Optional) When Incydr creates a new agent for a duplicate ID, you can:
- Update the agent name so it does not include "duplicate 1".
- Deactivate the duplicate agent.
Additional resources
- To view a list of computer IDs in your environment, go to Administration > Environment > Agents > Active > Export.
- To resolve duplicate computer IDs manually, see Assign your computer a new ID.
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